Web PVR: "Unable to create server socket: Permission denied" error on startup
#1
Hello there,

I'm running Windows 10 Pro and I keep it up to date.

I'm running the latest version of get_iplayer 3.01.0.

I've been using get_iplayer for a long time without any problems at all but today the Web PVR Manager wouldn't open in any browser. I get...

"This site cannot be reached. localhost refused to connect"

and...

"ERR_CONNECTION_REFUSED"

I've checked for a problem with my internet connection but there isn't one.

I tried reinstalling get_iplayer but this hasn't solved the problem.

Looking at the get_iplayer cli I get the following...

Unable to create server socket: Permission denied at C:\Program Files (x86)\get_iplayer\get_iplayer.cgi line 272

I'm a novice with cgi scripts so can't work out why this has suddenly started to happen.

I'm not using a VPN and I'm in the UK.

Any help would be much appreciated.

Thanks.
#2
A possible culprit is a third-party antivirus/firewall. You may need to explicitly exempt the Perl interpreter (C:\Program Files (x86)\get_iplayer\perl\perl.exe) from whatever restrictions prevent it from opening a network socket. You would have to figure out how to do that for your particular antivirus/firewall.
#3
Hi there,

Thanks for your quick reply.

I use Bitdefender and have just checked the firewall rules.

Sadly, perl.exe already has a rule - bi-directional - any network - allow.

I've attached a .jpg of the browser page, the PVR cli output and the firewall rules.

It's quite bizarre as I was having no issues until yesterday.

Am wondering if it's a Windows 10 update that's to blame?

Thanks,

S.


Attached Files Thumbnail(s)
       
#4
The browser error is irrelevant. It just reflects the fact that the Web PVR server couldn't launch. If you didn't add the firewall rule for perl.exe, you might check that it applies to the perl.exe installed with get_iplayer (unless it is supposed to apply to any perl.exe). The next logical step is to completely disable Bitdefender (including any system services it launches) and attempt to run the Web PVR again.
#5
Hello again,

I did all of the things you suggested but nothing solved the problem until I completely removed get_iplayer from my system using a smart uninstaller and then did a fresh reinstall from scratch.

It's now working again. Still a bit bizarre that this happened. After disabling the bitdefender firewall, making sure the windows firewall was off get_iplayer would still refuse to work.

Anyway, all is well now.

Thanks very much for your help Dinky.

S.
#6
Good news. "Permission denied" is a pretty generic error that might mean any number of things. One of the hazards of providing Perl with get_iplayer is that a bad install can lead to cryptic system errors like that. Delete and reinstall is never a bad idea in that case.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Could not create default output directory after reinstall Koyangi 9 1,628 03-09-2016, 11:44 AM
Last Post: Koyangi
  Can't create file that already exists alanem 6 1,405 16-10-2015, 07:24 PM
Last Post: alanem
  ERROR: RTMP_Connect0, failed to connect socket. 10060 (Unknown error) Fenntil 1 1,984 04-10-2013, 05:28 PM
Last Post: SquarePenguin