Radio downloads fail when using invalid --aactomp3 option
#1
Hi folks,

Having installed get_iplayer 3.0.0 and 3.0.1, my downloads of TV programmes are working fine, but nothing has been working in terms of downloading radio programme. I am, for example, using this sort of code: get_iplayer --pid=b08yrm17 --type=radio --aactomp3

An error message always comes up: 'Assumed to be ffmpeg 3.0 or higher unless --ffmpeg-obsolete'.

Can anyone advise me what to do to get radio show downloads working again?

Many thanks,
Tom
#2
You could do worse than scroll back and read the beginning of the output. --aactomp3 is no longer a valid option, so get_iplayer dumps a usage message.
#3
(26-07-2017, 06:55 PM)dinky Wrote: You could do worse than scroll back and read the beginning of the output. --aactomp3 is no longer a valid option, so get_iplayer dumps a usage message.

Thank you!
#4
It is possible to convert downloaded radio to MP3, see e.g. https://github.com/get-iplayer/get_iplay...i/aactomp3

If, like me, you want to convert all your radio programs to mp3, see the section here


Possibly Related Threads...
Thread Author Replies Views Last Post
  Reinstalling - fail mediapenguin 1 264 28-06-2017, 07:16 PM
Last Post: dinky