Raspbian: precompiled ffmpeg available
#1
While we wait for Raspbian to move back to ffmpeg this chap has precompiled ffmpeg for raspbian. It saves having to compile it manually which is time consuming.

Just ssh and run these commands:

Code:
wget https://github.com/ccrisan/motioneye/wiki/precompiled/ffmpeg_3.1.1-1_armhf.deb
sudo dpkg -i ffmpeg_3.1.1-1_armhf.deb

Then configure get_iplayer to use ffmpeg instead:

Code:
get_iplayer --add-prefs --ffmpeg="/usr/bin/ffmpeg"

p.s. This also allows you to download the new HVF streams.
#2
Thanks for providing this information. If anyone else has used this - successfully or otherwise - please post with your results. The next release of get_iplayer (coming very soon) will require the proper ffmpeg instead of libav, so it would be helpful to know if this is a suitable option for Raspbian. I have no way to test it myself.
#3
(10-08-2016, 03:33 PM)dinky Wrote: If anyone else has used this - successfully or otherwise - please post with your results.

On a sample of one downloaded programme, this version of ffmpeg works fine.

Jon
#4
Sorry for delayed reply.
Yes, this version of ffmpeg has worked well for me with v2.95 on Raspbian.
I've only had one downlioad with a missing segment as you've described and fixed in the v2.96 release notes.
#5
I've tried installing ffmpeg, but I hit the following error


Code:
[email protected]:~ $ sudo dpkg -i ffmpeg_3.1.1-1_armhf.deb
(Reading database ... 133186 files and directories currently installed.)
Preparing to unpack ffmpeg_3.1.1-1_armhf.deb ...
Unpacking ffmpeg (3.1.1-1) ...
dpkg: error processing archive ffmpeg_3.1.1-1_armhf.deb (--install):
trying to overwrite '/usr/include/libavfilter/avfilter.h', which is also in package libavfilter-dev 6:11.7-1~deb8u1+rpi1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
ffmpeg_3.1.1-1_armhf.deb

Any help would be much appreciated
#6
(10-09-2016, 10:01 AM)PBigTA78 Wrote: I've tried installing ffmpeg, but I hit the following error

Code:
[email protected]:~ $ sudo dpkg -i ffmpeg_3.1.1-1_armhf.deb
[...]
trying to overwrite '/usr/include/libavfilter/avfilter.h',
which is also in package libavfilter-dev
[...]

Any help would be much appreciated

There's evidently a clash between the libav packages and ffmpeg.  Try removing libav first.

Specifically, the error is telling you that there's a clash with libav-filter-dev, but removing just that is likely to result in another similar error for the other libav-dev packages, and possibly libav itself.

Jon
#7
I might be barking up the wrong tree, but would suggest you reboot the raspberry pi and ensure get_iplayer or anything else that might be using libav is not running before you run these commands.


Possibly Related Threads...
Thread Author Replies Views Last Post
Bug Raspbian - expired repository signing key for packages.hedgerows.org.uk jonhedgerows 0 106 05-01-2017, 11:46 PM
Last Post: jonhedgerows